Forum

Unified Communications PBX System

FollowMe not record...
 
Notifications

FollowMe not recording  

  RSS

TieFighter
(@lmoreira)
Active Member
Joined: 1 year ago
Posts: 17
29/01/2020 11:00 am  

Guys,

I have a DID going to a QUEUE, if QUEUE is empty, then call is routed to followme.

Recording is activated on Incoming Route, and on QUEUE settings. Extension has recording on as well. But, when call goes to followme, no recording happen.

On asterisk log, I see this:

[2020-01-28 20:49:45] VERBOSE[18709][C-00000567] pbx.c: Executing [h@ext-followme:2] System("SIP/2431808685-00000a65", "rm -f /var/spool/asterisk/tmp/followme-1580255369.5444.wav") in new stack

So, file was deleted. On dialplan, indeed "rm -f" is deleting a temporary file. 

[ext-followme]
exten => FW11,1,NoOp(Follow Me: FW11)
same => n,Set(__SKIP_PLAYBACK=${IF($["${QUEUE_CALL}"="TRUE"]?TRUE:${SKIP_PLAYBACK})})
same => n,Set(CALLER_RECORDING=${ASTSPOOLDIR}/tmp/followme-${UNIQUEID}.wav)
same => n,Set(__O_RING_TIME=100)
same => n,Set(__SRC_APP=${IF($["${LEN(${SRC_APP})}"="0"]?FW11:${SRC_APP})})
same => n(start-dialing),NoOp(Start Dialing)
same => n,Gosub(sub-set-moh,s,1(ringback,YES))
same => n,Dial(Local/9XXXXXX@cos-all,100,r)
same => n,System(rm -f ${CALLER_RECORDING})
same => n,Return()

This is how it suppose to be, or am I missing something?

So, how record a call after send it to followme destination?


Quote
Topic Tags
mrivera
(@ing-joserivera26)
Developer Admin
Joined: 2 years ago
Posts: 2232
03/02/2020 11:28 am  

We will test it, and let you know the results. 


ReplyQuote
mrivera
(@ing-joserivera26)
Developer Admin
Joined: 2 years ago
Posts: 2232
04/02/2020 1:56 pm  

Update VitalPBX to version 2.4.0-5 to fix this issue.

Let me know if all is working after updating.


ReplyQuote
Share: