Forum

Unified Communications PBX System

Notifications
Clear all

[Solved] Error on editing extension: routing.php line 0  

  RSS

mo10
 mo10
(@mo10)
Estimable Member
Joined: 2 years ago
Posts: 169
19/10/2019 2:21 pm  

Hello,

please see the error attached.

Extension was not registered anymore one day so we tried to edit it. Just right after clicking the extension this error showed up.

How is this possible?
How to fix and hot wo avoid in the future?

Thank you!

This topic was modified 9 months ago by mo10

mrivera
(@ing-joserivera26)
Developer Admin
Joined: 2 years ago
Posts: 2355

mo10
 mo10
(@mo10)
Estimable Member
Joined: 2 years ago
Posts: 169
20/10/2019 2:32 pm  

@ing-joserivera26

Thanks but this must be a bug. We don't use FXO either and this happend just after a few days changing nothing!

How to avoid?

Thank you!


mrivera
(@ing-joserivera26)
Developer Admin
Joined: 2 years ago
Posts: 2355
20/10/2019 2:43 pm  

The only way to reproduce this is the some DID is pointing to that extension, and the DID have an invalid FXO device assigned. There's not another way.


mo10
 mo10
(@mo10)
Estimable Member
Joined: 2 years ago
Posts: 169
20/10/2019 2:46 pm  

@ing-joserivera26

Can you please send a screenshot or hint where to find this mistake?


mrivera
(@ing-joserivera26)
Developer Admin
Joined: 2 years ago
Posts: 2355
20/10/2019 2:50 pm  

Do you have an inbound route pointing to the extension you're trying to edit?


mo10
 mo10
(@mo10)
Estimable Member
Joined: 2 years ago
Posts: 169
20/10/2019 2:51 pm  

@ing-joserivera26

Yes we do.

We don't have any FXS-Ports, so how could it be possible to chose one that is wrong?

This post was modified 9 months ago by mo10

mrivera
(@ing-joserivera26)
Developer Admin
Joined: 2 years ago
Posts: 2355
20/10/2019 2:56 pm  

Try removing the DID that is pointing to the extension and try to editing it.

Then, create the DID again.


mo10
 mo10
(@mo10)
Estimable Member
Joined: 2 years ago
Posts: 169
20/10/2019 3:01 pm  

@ing-joserivera26

Works BUT we don't have any FXO or FXS Ports to choose from.
It's a VPS.

How can this happen from one day to another?

Thank you.


mrivera
(@ing-joserivera26)
Developer Admin
Joined: 2 years ago
Posts: 2355
01/11/2019 2:01 pm  

This has been solved on VitalPBX 2.3.8-3


Share: