Forum

Unified Communications PBX System

Help us to improve VitalPBX

Processing ...
USD

[Solved] Fax Module issues  

  RSS

pftech-pf
(@pft3ch-pa)
Active Member
Joined: 7 months ago
Posts: 13
05/10/2019 11:21 am  

Hi there,

we've bought fax module some weeks ago and we've done a lot of tests, with just partial success. We can receive fax and receive them through email correctly but they don't appear in the "Fax Viewer" tab to view them through the web gui.

Then, after a lot of tries, we're finally been able to send faxes but we never get sending notifications through email nor in the "Fax Viewer" tab in the web gui.

Anyone can help?

We'd like to use Vitalpbx just as a fax server and nothing else by now...

Regards,

Paolo


Topic Tags
fax
mrivera
(@ing-joserivera26)
Developer Admin
Joined: 2 years ago
Posts: 1673
05/10/2019 11:23 am  

What version of VitalPBX are you running, and what version of Virtual Faxes add-on are you using?


pftech-pf
(@pft3ch-pa)
Active Member
Joined: 7 months ago
Posts: 13
05/10/2019 5:35 pm  

@ing-joserivera26

Vitalpbx is version: 2.3.6-1

Virtual faxes add-on is version: 1.0.2-1

 

Regards

Paolo


mrivera
(@ing-joserivera26)
Developer Admin
Joined: 2 years ago
Posts: 1673
07/10/2019 9:58 am  

Try updating VitalPBX to its latest version, and also update the Virtual Faxes add-on.

Let me know if that fixes the issue.


pftech-pf
(@pft3ch-pa)
Active Member
Joined: 7 months ago
Posts: 13
07/10/2019 10:50 pm  

Hi there,

I've updated VitalPBX to 2.3.8-1 

But I cannot update VirtualFax 1.0.3-1 because everytime I try to do the upgrade through the webUI I get this error message:

Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: centos.crazyfrogs.org * epel: mirror.netweaver.uk * extras: centos.quelquesmots.fr * updates: centos.quelquesmots.fr Resolving Dependencies --> Running transaction check ---> Package vitalpbx-virtual-faxes.x86_64 0:1.0.2-1 will be updated ---> Package vitalpbx-virtual-faxes.x86_64 0:1.0.3-1 will be an update --> Processing Dependency: ghostscript = 9.07 for package: vitalpbx-virtual-faxes-1.0.3-1.x86_64 --> Finished Dependency Resolution Error: Package: vitalpbx-virtual-faxes-1.0.3-1.x86_64 (vpbx-addons) Requires: ghostscript = 9.07 Installed: ghostscript-9.25-2.el7_7.2.x86_64 (@updates) ghostscript = 9.25-2.el7_7.2 Available: ghostscript-9.25-2.el7.i686 (base) ghostscript = 9.25-2.el7 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest


Then if I try to do the update via ssh through the console using yum update, I get this error:

yum install vitalpbx-virtual-faxes-1.0.3-1.x86_64
Plugin abilitati:fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.crazyfrogs.org
* epel: fr2.rpmfind.net
* extras: centos.quelquesmots.fr
* updates: mirrors.ircam.fr
Risoluzione dipendenze
--> Esecuzione del controllo di transazione
---> Pacchetto vitalpbx-virtual-faxes.x86_64 0:1.0.3-1 settato per essere installato
--> Elaborazione dipendenza: ghostscript = 9.07 per il pacchetto: vitalpbx-virtual-faxes-1.0.3-1.x86_64
--> Elaborazione dipendenza: hylafax+ >= 5.6.1 per il pacchetto: vitalpbx-virtual-faxes-1.0.3-1.x86_64
--> Esecuzione del controllo di transazione
---> Pacchetto hylafax+.x86_64 0:7.0.0-1.el7 settato per essere installato
--> Elaborazione dipendenza: ghostscript per il pacchetto: hylafax+-7.0.0-1.el7.x86_64
---> Pacchetto vitalpbx-virtual-faxes.x86_64 0:1.0.3-1 settato per essere installato
--> Elaborazione dipendenza: ghostscript = 9.07 per il pacchetto: vitalpbx-virtual-faxes-1.0.3-1.x86_64
--> Esecuzione del controllo di transazione
---> Pacchetto ghostscript.x86_64 0:9.25-2.el7_7.2 settato per essere installato
---> Pacchetto vitalpbx-virtual-faxes.x86_64 0:1.0.3-1 settato per essere installato
--> Elaborazione dipendenza: ghostscript = 9.07 per il pacchetto: vitalpbx-virtual-faxes-1.0.3-1.x86_64
--> Risoluzione delle dipendenze completata
Errore: Pacchetto: vitalpbx-virtual-faxes-1.0.3-1.x86_64 (vpbx-addons)
Richiede: ghostscript = 9.07
Disponibile: ghostscript-9.25-2.el7.i686 (base)
ghostscript = 9.25-2.el7
Disponibile: ghostscript-9.25-2.el7_7.2.i686 (updates)
ghostscript = 9.25-2.el7_7.2
Si può provare ad usare --skip-broken per aggirare il problema
Provare ad eseguire: rpm -Va --nofiles --nodigest

(sorry for italian language console)

 

Tried also to remove ghostscript and hylafax without success.

 

Best regards,

Paolo


mrivera
(@ing-joserivera26)
Developer Admin
Joined: 2 years ago
Posts: 1673
08/10/2019 11:38 am  

We've released a new version of Virtual Faxes add-on in order to fix the requirements of the package and adding compatibility with the latest version of Hylafax & Ghostscript's packages.

Please, clean the yum cache and try to update it again.


pftech-pf
(@pft3ch-pa)
Active Member
Joined: 7 months ago
Posts: 13
08/10/2019 10:37 pm  

Ok thanks, now it works again and it finally archives fax received and sent. We're having some troubles with (I think) codecs and other stuff like that for sending and receiving fax over voip. Is there a way to configure Virtual Fax module using a specific bit rate, disabling error correction, etc.. ?

 


pftech-pf
(@pft3ch-pa)
Active Member
Joined: 7 months ago
Posts: 13
08/10/2019 11:43 pm  

I've noticed that I get into "Fax Viewer" just sent fax... I only get received ones through email, but I cannot see them in Fax Viewer.

Is there a way to fix this?

Regards,

Paolo


mrivera
(@ing-joserivera26)
Developer Admin
Joined: 2 years ago
Posts: 1673
09/10/2019 5:15 pm  

How do you have configured your Inbound Routes? Do you have some screenshot?


pftech-pf
(@pft3ch-pa)
Active Member
Joined: 7 months ago
Posts: 13
09/10/2019 10:13 pm  

We're currently testing it and we've setup an unique inbound routes to forward everything through and extension with fax email enabled.

I attach the screenshot.

 

This post was modified 1 week ago by pftech-pf

mrivera
(@ing-joserivera26)
Developer Admin
Joined: 2 years ago
Posts: 1673
10/10/2019 9:25 am  

You're sending the faxes to the wrong destination on Inbound Routes. When using the Virtual Faxes add-on, you must point incoming faxes to "Fax Devices" destination, and select one of the fax devices you've created. Check the attached picture.


pftech-pf liked
pftech-pf
(@pft3ch-pa)
Active Member
Joined: 7 months ago
Posts: 13
10/10/2019 12:16 pm  

It works!!! Great!! Thank you very much!

Now we finally can do fax mail service using VitalPBX! Great!

Best regards!


Share:

Please Login or Register