Forum

Unified Communications System


Outgoing External C...
 

[Solved] Outgoing External CID not showing as set for extension  

  RSS

JanBergner91
(@janbergner91)
New Member
Joined: 3 weeks ago
Posts: 2
25/02/2019 1:41 am  

I have the following Problem:

If i take a call outside the PBX: internal -> external : the number i set in extension config is not shown. instead the provider fallback number is provided. The provider is Sipgate. The support tells me that there is no SIP-Header like (P-Preferred-Identity: sip:492111234567@sipconnect.sipgate.de) provided. I have not found any solution in the config.

 

Has anybody an idea?


Quote
mrivera
(@ing-joserivera26)
Developer Admin
Joined: 1 year ago
Posts: 997
25/02/2019 9:24 am  

That's a requirement specifically for that VoIP Provider.  What you can do is modify the "sub-construct-cid" context, located at /etc/asterisk/ombutel/extensions__20-baseplan.conf, however, this file is overwritten each time the Software is updated to a new version.

You should modify the s-external extension on "sub-construct-cid", and add the required headers.


ReplyQuote
JanBergner91
(@janbergner91)
New Member
Joined: 3 weeks ago
Posts: 2
28/02/2019 12:34 am  

Hello mrivera,

i have now contacted some other SIP-Providers (5) and 4 of them require exactly this Header (P-Preferred-Identity). I tested this settings in 3CX and it worked perfectly. But i am still on VitalPBX-Way. Is there any possibility to add this as Feature?


ReplyQuote
mrivera
(@ing-joserivera26)
Developer Admin
Joined: 1 year ago
Posts: 997
01/03/2019 8:46 am  

We will try to add this feature for the next version. Thanks for using VitalPBX


ReplyQuote
mrivera
(@ing-joserivera26)
Developer Admin
Joined: 1 year ago
Posts: 997
14/03/2019 10:29 am  

Now is possible to define custom SIP / PJSIP headers per trunk on Version 2.3.0


ReplyQuote
Share:
  
Working

Please Login or Register