Unified Communications PBX System

Clear all

RTP While Recording  


Estimable Member
Joined: 10 months ago
Posts: 102
25/04/2020 3:34 pm  

Hi everyone,

We recently came across a hair pulling situation where one of our PBXs stopped sending RTP as soon as it started recording voicemails and eventually terminated the call after 30 seconds, but it only happened when we called from a PBX in the same DataCenter. 

No NAT issues, no Direct RTP, we've gone through the basic and advanced troubleshooting with no luck.

Until we found this:

We added it under SIP Settings > Custom, restarted Asterisk and it started sending RTP.

You can see the setting if it is enabled or disabled by running 'core show settings'

So I hope someone who is in the same boat as us won't have to go through the pain we went through, and finds this post easily..

Perhaps the VitalPBX Team can make this the default, I see other major Asterisk re-compilers also have this enabled by default.

Thank you

mo10 liked
Topic Tags
New Member Customer
Joined: 3 months ago
Posts: 1
01/05/2020 2:23 pm  

Just would like to take feedback that after making changes to transmit_silence=yes how is recording and calls working since.

Anything you would like to add?

Estimable Member
Joined: 10 months ago
Posts: 102
25/05/2020 5:21 am  

UPDATE: After looking at this, adding these parameters in the GUI does not even work, because it adds it under the [general] settings in /etc/asterisk/ombutel/sip__10-general.conf

It needs to be added under [options].

I found under /etc/asterisk/ombutel/asterisk__20-maxfiles.conf:

maxfiles = 20000

So I manually added:


And I restarted Asterisk.

1) Is it possible to add these from the GUI?

2) Is it possible to have this be the default?


Developer Admin
Joined: 2 years ago
Posts: 2355
26/05/2020 6:21 pm  

I think this parameter doesn't come by default because it is not used often. it's a very particular situation what is happening to you