Forum

Unified Communications PBX System

Help us to improve VitalPBX

USD

VitalPBX under NAT  

  RSS

khuyenht
(@khuyenht)
New Member
Joined: 2 weeks ago
Posts: 4
07/11/2019 10:19 am  

Hi All,

My diagram

INTERNET<-NAT->Firewall  - VitalPBX ( 10.x.x.x) -IPphone

I use SIP trunk to my service provider , incoming/outgoing call working fine until today.

I can't call out and receive any call from our VOIP service provider. after debug VOIP service provider answer they only received voip data from my VItalPBX private IP ( 10.x.x.x) not from my Internet IP so they reject my voip data.

i have checked NAT configuration in Firewall , everything seem working fine except voip.

Could you please help me to resolve this issue.

Thanks you so much.

 


Quote
Topic Tags
mrivera
(@ing-joserivera26)
Developer Admin
Joined: 2 years ago
Posts: 1827
08/11/2019 2:42 pm  

Do you have multiple network interfaces?


ReplyQuote
khuyenht
(@khuyenht)
New Member
Joined: 2 weeks ago
Posts: 4
09/11/2019 9:22 am  

@ing-joserivera26

Hi Mrivera,

i have only 1 network card ( 1 IP private 10.x.x.x)

Thank you


ReplyQuote
mrivera
(@ing-joserivera26)
Developer Admin
Joined: 2 years ago
Posts: 1827
10/11/2019 12:40 pm  

Did you define your Public and Private IP address on SIP Settings?


ReplyQuote
khuyenht
(@khuyenht)
New Member
Joined: 2 weeks ago
Posts: 4
10/11/2019 9:46 pm  

@ing-joserivera26

Hi Mrivera,

we don't define Public and private IP in SIP setting, i keep the default setting.

~

below is our /etc/asterisk/ombutel/sip__10-general.conf

[general]
context=sip-default
udpbindaddr=0.0.0.0:5060
tcpbindaddr=0.0.0.0:5060
tlsbindaddr=0.0.0.0:5061
tlscipher=ALL
tlsclientmethod=tlsv1
accept_outofcall_message=yes
allow=!all,ulaw,alaw,g729,g722,gsm
allowguest=no

allowtransfer=yes
alwaysauthreject=yes
authfailureevents=no
autoframing=no
defaultexpiry=120
dumphistory=no
dynamic_exclude_static=no
faxdetect=no
g726nonstandard=no
jbenabled=no
jbforce=no
jbimpl=fixed
language=en
maxcallbitrate=384
maxexpiry=3600
minexpiry=60
notifycid=no
notifyhold=no
notifyringing=yes
preferred_codec_only=no
recordhistory=no
rtpholdtimeout=300
rtptimeout=30
sipdebug=no
srvlookup=no
tonezone=us
tos_audio=ef
tos_sip=cs3
tos_video=af41
videosupport=no
nat=no
websocket_enabled=true
autodomain=no
allowexternaldomains=yes
tcpenable=no
tlsenable=no
tlsdontverifyserver=no
useragent=VitalPBX
callcounter=yes
tos_text=af41
cos_sip=3
cos_audio=5

Could you please help,

Thank you so much

 


ReplyQuote
khuyenht
(@khuyenht)
New Member
Joined: 2 weeks ago
Posts: 4
12/11/2019 8:44 am  

Hi Mrivera,

the service provider block our connect because VitalPBX use private IP when send packet to service provide.

https://uphinh.vn/image/rPLNE

could you please support me configure Vitalpbx using Public IP addres.

Thanks so much

 

 


ReplyQuote
olegbo
(@olegbo)
Active Member Customer
Joined: 1 week ago
Posts: 7
13/11/2019 12:14 pm  

If you have static public IP address, it's must be configured in SIP settings.


ReplyQuote
olegbo
(@olegbo)
Active Member Customer
Joined: 1 week ago
Posts: 7
13/11/2019 12:21 pm  

You need to config localnet address too.


ReplyQuote
Share:

Please Login or Register